Business Administrator - General

1.  Problem

When I try to edit a Team in Business Administrator to change its status from Out of Service to In Service, I get the following error message:

Please configure the database server you have connected to for DATA ACCESS.

Solution

In a distributed server scenario, set the value of the Data Access option to True in the Linked Servers Properties dialog box for all the computers where CRM databases are installed. To do so:

a.  Open SQL Server Management Studio

b.  Navigate to the Server Objects\Linked Servers folder.

c.  Right-click on the server name where a CRM database is installed and select Properties from the shortcut menu.

d.  The Linked Server Properties window is displayed.

e.  Click the Server Options in the left pane.

f.  In the right pane, ensure that the value of the Data Access option is set to True.

2.  Problem

If the Business Administrator User performs database intensive operations in Business Administrator when database replication is in progress, Business Administrator is slow to respond.

Solution

Perform the operations in Business Administrator after the replication operation is complete.

3.  Problem

Occasionally, when a number of Properties are deleted in quick succession from Business Administrator, replication fails, and the following error is logged in Replication Monitor.

Invalid column name 'FldNumericXXXXXXXX'.

This error is followed by stored procedure, and table name details.

Solution

The error corresponds to Error 207 in MS SQL Server Replication Monitor. The error will contain the name of the article in which the error has occurred. Using Database Administrator, drop the article mentioned in the error, and add it again.

Example

If the following error is logged in Replication Monitor, you need to drop, and add the tblObjectType7_1 table again.

Invalid column name 'FldNumericXXXXXXXX'."

Create procedure [sp_MSins_tblObjectType7_1] @c1 int,@c2

datetime,@c3 datetime,@c4 int,@c5 int,@c6 nvarchar(255),@c7

nvarchar(255),@c8 nvarchar(255),@c9 nvarchar(255),@c10

nvarchar(255),@c11 nvarchar(255),@c12 nvarchar(255),@c13

nvarchar(255),@c14 int,@c15 datetime,@c16 int,@c17

nvarchar(255),@c18 nvarchar(255),@c19 int,@c20 int,@c21 int,@c22

nvarchar(255),@c23 int,@c24 int,@c25 int,@c26 nvarchar(255),@c27

nvarchar(255),@c28 int,@c29 int,@c30 int,@c31 decimal(19,6),@c32

decimal(19,6),@c33 decimal(19,6),@c34

Transaction sequence number and command ID of last execution batch are

0x000032EC0000012C000100000000 and 29.

Invalid column name 'FldNumeric22091'.

Invalid column name 'FldNumeric22091'.

(Source: TALISMALAB18\INST1 (Data source); Error number: 207)

4.  Problem

I am unable to view the left pane in Business Administrator. This behavior is inconsistent.

Solution

The Enable Parent Paths option is not selected in the virtual root of Business Administrator.

a.  From the Start menu, select Programs, Administrative Tools, Internet Information Services (IIS) Manager.

The Internet Information Services Manager screen is displayed.

b.  In the Connections pane, expand the computer name.

c.  Navigate to the Sites\ Default Web Site\<Talisma Business Administrator> node.

d.  In the Features View tab, under the IIS area, double-click ASP.

e.  Set the value of the Enable parent paths option to True.

f.  In the Actions pane, click Apply.

5.  Problem

When I upgrade the license, the license update information is not reflected in Business Administrator.

Solution

The Application Server must be restarted by restarting the Application Server component in the Component services. To do so:

a.  From the Start menu, select Programs, Administrative Tools, Component Services.

The Component Services window is displayed.

b.  Browse to the following path: Console Root/Component Services/Computers/My Computer/COM+ Applications.

c.  Right-click the TLSysCore component, and select Shut down from the shortcut menu.

d.  Right-click the TLSysCore component, and select Start from the shortcut menu.

Note

Ensure that all Users are logged off before you restart Application Server.

6.  Problem

Business Administrator window does not resize when I maximize the browser.

Solution

Click Refresh on the toolbar.

7.  Problem

Data displayed in Business Administrator is not updated.

Solution

Log off from Business Administrator, close the browser, and clear the cache. Log on to Business Administrator.

8.  Problem

When I try to create an Object in Business Administrator, an “Unspecified error” message is displayed. Also, the Property table is created only in Main database and not in Media Database.

Cause

Main database and Media database are installed on different computers, and you are trying to create an Object in Business Administrator when Media database is down.

Solution

Ensure that the Microsoft® Distributed Transaction Coordinator (DTC) service is running on the computer where Media Database is installed. If the DTC service is not running, the User creation operation will fail. In addition, you need to check whether Media Database is running.