Database Administrator - General
1. Problem
I am not able to enable traces for CampusNexus CRM Services.
Solution
If CampusNexus CRM Services are created on the Database Administrator computer, enable traces from Trace Client that is available on the Database Administrator computer.
OR
If CampusNexus CRM Services are created on a different computer, perform the following steps before enabling traces in Trace Client:
a. Copy the following files from the Talisma Shared folder on the Main database computer to the Talisma Shared folder on the CampusNexus CRM Services computer.
◦ MSCOMCTL.ocx
◦ Trace Client.ocx
◦ Trace Client.exe
◦ EventLogMessages.reg
◦ TLEventMessages.dll
b. Register the MSCOMCTL.ocx and Trace Client.ocx files by typing the following command in the Run dialog box:
Regsvr32 <<Drive name>:\Program Files\Common Files\Talisma Shared\<File name>.
Replace the value <File name> with MSCOMCTL.ocx and Trace Client.ocx
c. Press Enter.
d. Double-click EventLogMessages.reg.
Traces for CampusNexus CRM Services can now be enabled from Trace Client.
2. Problem
If IP to Name resolution fails on a computer where CampusNexus CRM Services are installed, operations performed in Database Administrator on any service results in an error with the following message:
The Machine on which the service is installed is unreachable, Do you want to remove the service related entries from Talisma DB?
Solution
Click No on the error message dialog box, resolve the IP to Name issue and then perform the required operations on CampusNexus CRM Services.
3. Problem
When I log on to Database Administrator, I get the following error message:
Unable to initialize Talisma Application Server. Contact your System Administrator.
Solution
On the computer where Application Server is installed, perform the following steps:
a. Go to the Control Panel and click the System Security link.
b. Click the Windows Firewall link.
The Windows Firewall window is displayed.
c. In the left pane, click the Advanced settings link.
The Windows Firewall with Advanced Security window is displayed.
d. In the left pane, click Inbound Rules.
e. In the right pane, ensure that COM+ Network Access (DCOM-In) and COM+ Remote Administration (DCOM-In) are enabled.
4. Problem
Following error message is displayed when the Configure Replication option is selected in Database Administrator:
Solution
On Distributor server perform the following steps:
◦ Run the following SQL Statements on the Distributor database:
Declare @tSnapshotAgentName nVarchar(500)
Select @tSnapshotAgentName = name From MSsnapshot_agents
Select * From sys.sysprocesses Where program_name = @tSnapshotAgentName
If the above SQL statements return a result, perform the following steps:
a. Restart the SQL Server service on the Distributor server.
b. Restart the SQL Server Agent service on the Main server.
◦ Re-configure the database replication.
5. Problem
When I try to log on to Database Administrator, the following error message is displayed, and I am unable to log on to Database Administrator.
Unable to connect to database.
Cause
Internal permissions were not set for the administrator on the Main Database on which the sample database is installed.
Solution
Run the following SQL query on Main database.
EXEC master..sp_addsrvrolemember @loginame = <login name>, @rolename = N'sysadmin'
6. Problem
From Database Administrator, when the administrator creates an external data source on an SQL Server 2012 computer, the following error message is displayed, and the external data source is not created:
Unable to initialize namespace object SQL DMO. Check your Microsoft SQL NS installation. Error # 80040154.
Solution
From SQL Server 2012 Management Studio, manually create the external data source on the SQL Server 2012 computer. Alternatively, if you want to create the external data source from Database Administrator, install MS SQL Server 2012 Client Tools, and then create the external data source. The error message will no longer be displayed.
7. Problem
In Database Administrator, when I register a server that is on a different network (subnet) using DCOM, I am unable to log on to the new server.
Solution
Use the appropriate workaround:
a. You can work in different domains in DCOM by modifying the following Security details for the Application Server COM+ Application:
◦ Authentication Level = None
◦ Impersonation Level = Anonymous
To do so:
b. From the Control Panel, open Administrative Tools, and double-click Component Services.
c. Click the plus sign (+) next to the Component Services node and select the Computers node.
d. Click the plus sign (+) next to the Computers node and select the My Computer node.
e. Click the plus sign (+) next to the My Computer node and select the COM+ Applications node.
f. Click the plus sign (+) next to the COM+ Applications node and select the TalismaApplicationServer node.
g. Right-click the TalismaApplicationServer node and select Properties from the shortcut menu. The TalismaApplicationServer Properties dialog box is displayed.
h. Select the Security tab and remove the selection of the Enforce access checks for this application option in the Authorization area.
i. From the Impersonation level list, select Anonymous.
j. Click OK.
- OR -
Steps provided in Microsoft Knowledge Base Article Number 158508.
8. Problem
When I try to drop replication from Database Administrator, the following error message is displayed:
“Invalid object name 'msdb..MSdistpublishers”
Cause
Replication has already been dropped from Microsoft SQL Management Studio.
Solution
Ignore the error message.
Note
It is recommended that you drop and configure replication from Database Administrator, and not from Microsoft SQL Management Studio.
9. Problem
When the SQL Server services are running under a Local Account, (for example the Administrator account), and I try to create and access a linked server, the following error message is displayed:
“Unable to connect to the database. The database server could be down.”
Solution
Ensure that the Microsoft® SQL Server™ services account is a domain account with local administrator permissions to access all objects in Main database.
10. Problem
When I log on to Database Administrator using trusted security, I encounter the following error message when accessing a Microsoft® Access or Excel external data source:
“Unable to complete the operation due to the following errors:
Error 7399 :: OLE DB provider 'Microsoft.Jet.OLEDB.4.0' reported an error.
Error 7312 :: [OLE/DB provider returned message: Unspecified error]”
Solution
You can connect to a Microsoft® Access or Microsoft® Excel external data source only by logging on to Main database using Application Security.
11. Problem
The count in tbloutgoingOBMs is not decreasing.
Cause
This could be because of one or more of the following reasons:
◦ The Mail server was not reachable.
◦ The Mail server was not ready to accept e-mail messages.
◦ The Mailer was not able to reach the database.
Solution
Check for “MilliSeconds to wait”. This is the wait time between two successive e-mail messages, before they are submitted to the Mail server.