Unable to Login After Registering on the Portal

Problem

After a fresh installation of the portal on a new or existing Reach environment, when a user registers on the portal and tries to login, an error is displayed and the user is unable to login to the portal.

Cause

The TPC Users role is not assigned to the newly registered portal user.

Solution

When a user registers on the portal, the portal user is assigned the Users role automatically in addition to the following portal roles depending on the type of portal user:

  • CMC_Student

  • CMC_Faculty

  • CMC_Agent

  • CMC_Recommender

To ensure that the portal user is assigned the required roles on portal, perform the following steps: