Unable to Login After Registering on the Portal
Problem
After a fresh installation of the portal on a new or existing Reach environment, when a user registers on the portal and tries to login, an error is displayed and the user is unable to login to the portal.
Cause
The TPC Users role is not assigned to the newly registered portal user.
Solution
When a user registers on the portal, the portal user is assigned the Users role automatically in addition to the following portal roles depending on the type of portal user:
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CMC_Student
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CMC_Faculty
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CMC_Agent
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CMC_Recommender
To ensure that the portal user is assigned the required roles on portal, perform the following steps:
In the Reach environment where the portal is installed, verify whether the newly registered portal user is assigned the Users role. To do so:
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Navigate to the Advanced Settings page and under Settings > Extensions, click Portals.
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On the Active Portals page, in the Name column, click the required portal URL.
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On the Portal Information page, in the Portal Users section,locate the required user, and double-click on the empty space in the Name column as shown in the following image:
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On the Portal User: Information page, click on the user name in the main navigation, and select Portal User Roles.
The Portal User Role Associated View page is displayed.
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Verify whether the Users role is present in the list of roles.
If the Users role is not present, assign the Users role to the portal user on the Sitefinity administrators site.
On the Sitefinity administrators site, assign the Users role to the portal user. To do so:
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Navigate to the Sitefinity administrator site and go to the Users page (under Administration > Users).
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In the Users page,
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From the list of users, select the user(s) for which the Users role is missing.
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Click the Assign to role button.
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In the Assign users to drop-down, select the Users role and click the Assign button.
The selected role will be assigned to the selected portal user(s).